O Java Code Sprint 2018 foi um evento ambicioso que reuniu projetos Java da OSGeo para analisar a compatibilidade com Java 11. Com uma ótima resposta da comunidade, o GeoServer agora pode rodar no Java 11!


GeoServer Server Status Page

Esse sprint foi uma resposta importante da comunidade às mudanças do Java. A motivação imediata é dar aos usuários a opção de usar o Java 11 na próxima versão do GeoServer (2.15.x), agora que o OpenJDK está assumindo como projeto principal. Também temos o prazer de informar que o Java 8 continuará sendo suportado (graças ao compromisso da RedHat e da Adopt OpenJDK), dando a todos a oportunidade de migrar quando estiverem prontos.

É importante observar que o Java 11 não suporta mais o mecanismo de extensão usado para as bibliotecas JAI e ImageIO nativas. Onde as bibliotecas podiam ser instaladas diretamente no Sistema Operacional para aumento de performance das mesmas.

Como experimentar:

1. Faça o download e instale o Java 11 (jdk.java.net/11)

2. Faça o download do GeoServer 2.15-M0

3. O GeoServer 2.15-M0 será executado sob o Java 11 sem configuração adicional no Tomcat 9 ou mais recente e no Jetty 9.4.12 ou mais recente.

4. A distribuição binária inclui uma versão compatível do Jetty.

Fonte: GeoServer Blog